HDD Power management.

Found a bug? Report here
Az7
Level 2
Level 2
Posts: 6
Joined: Wed Jul 08, 2020 12:15 pm

Re: HDD Power management.

Post by Az7 »

support wrote:
Mon Jul 20, 2020 4:29 pm
Could you try setting APM to 0?
I try 0 but nothing changed ..

Anyway I found a workaround ..

I changed Link power management mode from HIPM (default) to Active .. and problem solved.

See :
https://docs.microsoft.com/en-us/window ... -hipm-dipm

I use this command :
powercfg -attributes SUB_DISK 0b2d69d7-a2a1-449c-9680-f91c70521c60 -ATTRIB_HIDE

Thanks @support

User avatar
Support
Support Team
Support Team
Posts: 2749
Joined: Sun Dec 21, 2008 2:42 am

Re: HDD Power management.

Post by Support »

WOW! This explains why APM doesn't work on this issue. So in your case, both the HDD and the main board chipset (HBA) support HIPM/DIPM. When defer-write is on, less write activities on the HDD and HBA. Thus the HDD will be easy to enter the Partial or Slumber states with HIPM is enabled, even APM is disabled. The Partial or Slumber states will park the HDD heads, causing clicking sound.

We also see that by default Windows set AHCI Link Power Managment to active with in a High Performance power plan when power cord is plugged in. In other plans or on battery, Windows set it to HIPM.

I'm glad that you find a solution for it. And thank you very much for sharing your experience.
Primo Ramdisk | PrimoCache
Romex Software Support

Tobiwan
Level 3
Level 3
Posts: 18
Joined: Thu Sep 20, 2018 1:28 am

Re: HDD Power management.

Post by Tobiwan »

I'm using https://smarthdd.com/ to change the APM, since a time two of my HDDs doesn't save the setting anymore, but can't tell what I change because I don't notice it immediately. I wrote a few times with the developer of the tool, but we can't find a solution for the issue, it seems anything blocks access to restore/save the setting, so every restart the PC it returns to default.

I use Primo Cache alpha 4.0.0 with current Windows 10 2004 build 19041.338

The command "powercfg -attributes SUB_DISK 0b2d69d7-a2a1-449c-9680-f91c70521c60 -ATTRIB_HIDE" added a AHCI LPM - HIPM/DIPM

Unfortunately like every Microsoft document it is pretty shit, can someone tell me if active is right here? Because I have deactivate LPM in my BIOS, don't like it and don't care about the power.
There are Active, HIPM, DIPM, HIPM+DIPM and lowest

User avatar
Support
Support Team
Support Team
Posts: 2749
Joined: Sun Dec 21, 2008 2:42 am

Re: HDD Power management.

Post by Support »

The command "powercfg -attributes SUB_DISK 0b2d69d7-a2a1-449c-9680-f91c70521c60 -ATTRIB_HIDE" will show the hidden option "AHCI Link Power Management" in the Windows Power Options, as below figure shows. Then you can change the setting.
ALPM.png
ALPM.png (16.36 KiB) Viewed 95 times
Active: Link power management is not used.
HIPM: Host-Initiated Power Management (HIPM) is used.
HIPM and DIPM: HIPM and Device-Initiated Power Management (DIPM) are used.

Active means no spinning down Initiated by the host or the device, higher performance but more power consumption. If you don't want to stop HDD, then use Active.

AAM/APM will also control the behavior of HDD spinning down.
Tobiwan wrote:
Sun Jul 26, 2020 11:11 am
it seems anything blocks access to restore/save the setting, so every restart the PC it returns to default.
Do you enable the defer-write on HDDs?
Primo Ramdisk | PrimoCache
Romex Software Support

Tobiwan
Level 3
Level 3
Posts: 18
Joined: Thu Sep 20, 2018 1:28 am

Re: HDD Power management.

Post by Tobiwan »

Thank you for the information about the setting.

Yes, I have all HDDs set with enabled defer-write currently on a latency of 5 sec and mode intelligent, not sure about the defer-write, but the latency also was on 10 sec and native too without any change of the APM issue. I will test it without the defer-write setting.

The weird thing about all that APM on my side is, I have four HDDs, two directly connected to the mainboard and two on my Marvel controller and there was no problem in the past, any update of Windows, software, driver change that and it's hard to figure out what:

Two ST3000DM 001-1ER166 runs with my Marvell 92xx SATA 6G (ver. 1.2.0.1049)
Those two are save the APM setting

One TOSHIBA HDWE140 and one TOSHIBA HDWE160 on the mainboard with currently using Intel RST (ver. 17.9.2.1013)
Those two are doesn't save APM setting and resets every Windows restart

User avatar
Support
Support Team
Support Team
Posts: 2749
Joined: Sun Dec 21, 2008 2:42 am

Re: HDD Power management.

Post by Support »

Tobiwan wrote:
Mon Jul 27, 2020 1:55 pm
Those two are doesn't save APM setting and resets every Windows restart
I think this is the general case that HDD devices reset APM settings to their default values after reboot. Usually you need tools to adjust APM value each time Windows boots up.
Primo Ramdisk | PrimoCache
Romex Software Support

Tobiwan
Level 3
Level 3
Posts: 18
Joined: Thu Sep 20, 2018 1:28 am

Re: HDD Power management.

Post by Tobiwan »

I can confirm now, for my PC system, it is a "issue" with enabled defer-write.

Enabled defer-write = reset APM setting
Disabled defer-write = APM setting stay after reboot and power off

User avatar
Support
Support Team
Support Team
Posts: 2749
Joined: Sun Dec 21, 2008 2:42 am

Re: HDD Power management.

Post by Support »

When Defer-Write is enabled, HDD disks are easy to go to the park states because of less disk activities. This will result in a quick value increment in C1 data, or frequent parking (click) sound. So PrimoCache tunes APM setting in order to avoid these issues.
I misunderstood the "reset" in your previous posts. I thought you were talking about the issue that APM was reset to the disk default setting. Sorry.
Primo Ramdisk | PrimoCache
Romex Software Support

Tobiwan
Level 3
Level 3
Posts: 18
Joined: Thu Sep 20, 2018 1:28 am

Re: HDD Power management.

Post by Tobiwan »

With SmartHDD it is possible to change the APM of HDDs and I prefer to have every HDD to "more wasteful" with full 254. Usually it is only need to set it one time, SmartHDD runs at boot, and the setting stays.

A few weeks ago I notice that there was not anymore the case, strangely two of the HDDs saves the setting, the other two doesn't. I test a lot of things, write with the developer of SmartHDD about the problem, but can't find the reason for the issue. After I found the threat here I tried new things and found now that I can fix the issue with turn of the defer-write on my HDDs.

This issue with the APM setting is a new problem. I always use defer-write for my HDDs in the past the last 2 years, it seems the issue first occurred with the new alpha version 4.0.
Attachments
Primo1.png
Primo1.png (466.69 KiB) Viewed 28 times
SmartHdd.png
SmartHdd.png (81.11 KiB) Viewed 28 times

User avatar
Support
Support Team
Support Team
Posts: 2749
Joined: Sun Dec 21, 2008 2:42 am

Re: HDD Power management.

Post by Support »

Seems weird...4.0alpha doesn't change the code on the APM module. Besides, PrimoCache also sets the APM value to 254 by default when defer-write is enabled.
Primo Ramdisk | PrimoCache
Romex Software Support

Post Reply